نصب Zend Opcache روی PHP های قدیمی تر از ۵٫۵

سلامی دوباره و اینا 

گاهی اوقات مجبورم از PHP 5.5 قدیمی تر روی سرورها استفاده کنم ، اما از نعمت Extension خوبی مثل opcache محروم میشم.

داخل مخزن های remi و epel هم متاسفانه php-opcache فقط برای نسخه ۵٫۵ به بعد در دسترس هست. (البته تا امروز)

برای این کار نیاز به دسترسی root یا Super Privilege به سرور دارید.

۱. نصب PHP Pear روی سرور:

۲. نصب پکیج های مورد نیاز:

۳. داخل سایت Zend Opcache چک کنید آخرین نسخه چیست (در حال حاظر ۷.۰.۴) سپس نصب :

بعد از پروسه کامپایل و غیره و غیره می بایست یک فایل .ini ایجاد کنیم . (البته داخل php.ini اصلی هم میتونید modify کنید اما من پیشنهاد نمی کنم (شاید در آینده گفتم چرا) پس باید دایرکتوری ini یا کانفیگ php را پیدا و فایل زیر رو ایجاد کنید.)

۴. ایجاد opcache.ini در سرور

برای پیدا کردن Directory مربوط به فایل های کانفیگ (php .ini) دستور زیر را اجرا کنید.

به من دایکتوری زیر رو داده:‌

خب حالا فایل میسازیم و مقادیر مربوط به opcache را داخلش میگذاریم و وب سرور را ریستارت می کنیم.

 

برای اینکه مقادیر بالا رو Tune کنید حتما صفحه زیر رو بررسی کنید.

http://php.net/manual/en/book.opcache.php

تا درودی دیگر ، بدرود و اینا

 

منتشرشده توسط

دانیال گردی

من دانیال گردی ، دانشجوی رشته فناوری اطلاعات گرایش اینترنت و شبکه های گسترده ، متولد سال ۱۳۷۵، شاغل در شرکت داده پرداز و علاقه مند به مباحث مربوط به رایانش ابری ، میزبانی وب و لینوکس هستم.

پاسخ دهید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *